LynxEye for Windows Help

LynxEye for Windows ヘルプ 目次

このドキュメントはLynxEye for Windows ver1.1.3のヘルプファイルです。

導入編

LynxEye for Windows の概要

インストール

アンインストール

LynxEye for Windows ライセンス

使用許諾契約書

OpenCV BSDライセンス

ffmpeg.dll LGPライセンス

実用編

メイン画面

入力設定

COPYモード

出力設定

プレビュー

処理部

メニュー

ライセンス情報

ノイズリダクション


LynxEye for Windows の概要

目次－導入編－LynxEye for Windows の概要

LynxEye for Windows とは

BMP JPEG PNG、AVI MP4 WMV MOVなどの様々な動画像ファイルに、鮮明化処理を施すことができるアプリケーションです。

画像処理例：処理前（左）処理後（右）

動作環境

ＯＳ

MicrosoftWindows 7、8、10 (各OS 32bit/64bitに対応)

ＣＰＵ

Intel Core2 Duo 2GHz 以上または同等の互換プロセッサ

メモリ

動作：2GB以上　推奨：4GB以上

ＨＤＤ

150MB以上の空き容量(データ、作業スペースは除く)

サポート、連絡先など

サポート先

lynxsupport@cybercore.co.jp

株式会社　サイバーコア

http://www.cybercore.co.jp/

（最新版もコチラからダウンロード可能です）

更新履歴

2015/08/01 Ver.1.0.0 -- LynxEye for Windows リリース

2015/09/15 Ver.1.1.1 -- 試用版仕様変更

2015/11/05 Ver.1.1.2 -- UAC対応

2016/01/22 Ver.1.1.3 -- MP4対応 試用版仕様変更

ページの一番上に戻る


インストール方法

目次－導入編－インストール

インストールと起動の手順について解説します。

「LEW Installer.exe」を実行すると、セットアップウィザードが起動します。

「次へ(N) >」をクリック。

ライセンス条項が表示されますので良くお読み頂いた上で、「同意する(A)」にチェックを入れて「次へ(N) >」をクリック。

インストール先の指定と対象とするユーザーを設定します。宜しければ「次へ(N) >」をクリック。

「次へ(N) >」をクリックするとインストールが始まります。

以上でインストールは完了です。デスクトップ上に作られるショートカット、またはインストール先フォルダにある「LEW.exe」から起動できます。

※インストール後に起動出来ない場合の対処方法

「LynxEye for Windows」の起動及び動作には管理者権限が必須となります。

起動時に管理者権限に昇格する為のユーザーアカウント制御ダイアログが表示されない場合は、以下の手順をお試し下さい。

①ショートカットの右クリックプロパティから「ファイルの場所を開く(F)」からインストール先フォルダへ移動。

②LEW.exeの右クリックプロパティから互換性タブを選択。

③管理者としてプログラムを実行するチェックボックスをチェックする。


アンインストール

目次－導入編－アンインストール

アンインストールの手順について解説します。

※コントロールパネルからでもアンインストールは可能です。

「LEW Installer.exe」を実行すると、セットアップウィザードが起動します。

「削除(M)」にチェックをつけて、「完了(F)」をクリック。

以上でアンインストールは完了です。


LynxEye for Windows ライセンス

目次－導入編－LynxEye for Windows ライセンス

LynxEye for Windows ライセンスについて解説します。

試用版制限

LynxEye for Windodowsは処理結果出力に制限が設けられており、

処理結果をファイルとして出力することが出来ません。

(プレビューとして処理イメージを小窓で表示は可能)

ライセンス認証を行うことでその期間内、処理結果出力の制限が解除されます。

ライセンスの契約期間と料金

ライセンスの契約期間は1年、3年、5年からお選び頂けます。（ライセンス料金表を参照）

また、教育機関および官公庁ディスカウントは別途ご相談に応じさせて頂きます。

ライセンス料金表

契約年数 | 料金 | 1年あたり
1年 | 580 | 580
3年 | 1,485 | 495
5年 | 1,980 | 396

（千円：税別）

ライセンスの購入方法

LynxEye for Windows 起動後、ライセンスメニューよりライセンス情報、ライセンス購入と進み、

表示されているライセンスキー発行コードとご利用希望期間を併せて

lynxsupport@cybercore.co.jp　までご連絡をお願い致します。

詳しくはコチラをご覧ください。


使用許諾契約書

目次－導入編－使用許諾契約書

以下に使用許諾契約書の内容を記します。

*********************************************************

【使用許諾契約書】

  本許諾契約書（以下「本契約書」といいます）は、下記に示された株式会社
  サイバーコア（以下、単にサイバーコア）のソフトウェア製品（以下「本ソフト
  ウェア製品」といいます）に関して、お客様（個人または法人のいずれであ
  るかを問いません)とサイバーコアとの間に締結される法的な契約書です。

  本ソフトウェア製品は、コンピュータ ソフトウェアおよびそれに関連した
  マニュアルなどの文書を含みます。

  本ソフトウェア製品をインストールすることによって、お客様は本契約書の
  条項に拘束されることに承諾されたものとします。

  本契約書の条項に同意されない場合、サイバーコアは、お客様に本ソフトウェ
  ア製品の使用を許諾できません。
  そのような場合、未使用の本ソフトウェア製品を直ちに入手した場所へご返
  品いただければ、お支払いいただいた金額を全額払戻しいたします。

  ★★★ ライセンス対象製品 ★★★
  製   品   名	： 画像鮮明化ソフトウェアLynxEye for Windows
  ライセンス数	： １ ライセンス

  本ソフトウェア製品は、著作権法および著作権に関する条約をはじめ、その
  他の無体財産権に関する法律ならびに条約によって保護されています。

１． ライセンスの許諾
  本契約書は、お客様に対し以下の権利を許諾します。

(a) ソフトウェアの使用条件
  サイバーコアは、お客様の画像を鮮明化処理する目的にのみ、本ソフトウェア
  製品をインストールし使用する権利をお客様のPC１台のみに許諾します。

(b) 再頒布
  サイバーコアは、本ソフトウェアの再頒布は許諾しません。
  また、お客様が本ソフトウェアをインストールしたPCを第三者に譲渡する場
  合、お客様は本ソフトウェアをアンインストールするものとします。

２．その他の権利と制限

(a) リバースエンジニアリング、逆コンパイル、逆アセンブルの制限
  お客様は、本ソフトウェア製品をリバースエンジニアリング、逆コンパイル
  または逆アセンブルすることはできません。
  ※但し、FFmpeg.dllについてはLGPライセンスにならいます。
(b) レンタル
  お客様は本ソフトウェア製品をレンタル、リースまたは貸与することはでき
  ません。
(c) 解除
  お客様が本契約書の条項および条件に違反した場合、サイバーコアは、他の権
  利を害することなく本契約を終了することができます。
  そのような場合、お客様は本ソフトウェア製品の複製物およびその構成部分
  を全て破棄しなければなりません。

３． アップグレード
  本ソフトウェア製品がアップグレードである場合、お客様は、本ソフトウェ
  ア製品を使用するためには、サイバーコアからアップグレード対象のソフトウ
  ェア製品のライセンスを正規に取得していなければなりません。

  アップグレードである本ソフトウェア製品は、そのアップグレード対象のソ
  フトウェア製品を代替、あるいはこれに追加されるものです。
  お客様は、アップグレードにより得られた本ソフトウェア製品を、本契約書
  の条項に従ってのみ使用することができます。

４． 著作権
  本ソフトウェア製品および付属のドキュメント類、また本ソフトウェア製品
  の複製物についての著作権は、サイバーコアが有するもので、本ソフトは著作
  権法および著作権に関する条約の規定によって保護されています。

  したがって、お客様は本ソフトウェア製品を他の著作物と同様に扱わなけれ
  ばなりません。

  お客様は、本ソフトウェア製品付属のマニュアルなど印刷物を複製すること
  はできません。

  ただし、LynxEye for Windowsが動的リンクしている以下のDLLについては
  無償配布とし、そのライセンス条項は出典元の条項が原文のまま適用されます。
  詳しくは文末の各ライセンス条項の原文、または同梱されている
  opencv_BDSL.txt及び、ffmpeg_LGPL.txtまたはLEW.chmをご確認下さい。

  ・ opencv_core2410.dll   （ BSDライセンス ）
  ・ opencv_highgui2410.dll（ BSDライセンス ）
  ・ opencv_imgproc2410.dll（ BSDライセンス ）
  ・ opencv_ffmpeg2410.dll （ LGPLライセンス ）

  以上4点のDLLを含むOpenCVの配布元は以下URLより
  http://sourceforge.net/projects/opencvlibrary/files/opencv-win/2.4.10/

５．輸出規制
  お客様は、お客様またはお客様の顧客が、以下の製品、技術データ、サービ
  スを、輸出管理に関する法律等の手続きに従うことなく輸出しないことに同
  意するものとします。
 ( i) 本ソフトウェア製品または関連ドキュメントおよび技術データ
 (ii) お客様のソフトウェア製品、あるいは本ソフトウェア製品の直接の成果
      として得られるサービス

その他
  本契約は、日本国法に準拠するものとします。

  本契約についてのお客様からの問い合わせ等は、サイバーコア宛に書面、また
  はメールでお問い合わせください。

  お客様が、本ソフトウェア製品を日本国内で入手された場合の品質保証およ
  びその他の特別条項については、『品質保証規定』の通りとします。

*********************************************************

【品質保証規定】

  お客様が日本国で入手された本ソフトウェア製品に関しては、以下の保証の
  みが適用されます。
  本ソフトウェア製品の保証に関する事項は、サイバーコアを通じてのみ対処さ
  れるものとします。
  なお、この保証規定は、日本国内のみにて有効なものとします。

 (a) サイバーコアは、本ソフトウェア製品が付属の製品マニュアルに従って実質
     的に動作しない場合または本ソフトウェア製品の媒体またはマニュアルに
     物理的な瑕疵がある場合に、この製品入手後３０日間に限り、修補または、
     代金返還のいずれかにより対応するものとします。
 (b) 上記(a)項のいずれの対応も、お客様が本ソフトウェア製品の領収書（ま
     たは購入を証するもの）とともに本ソフトウェア製品をサイバーコアに返却
     された場合にのみ提供されます。
 (c) 上記(a)項の事態が火災、地震、第三者による行為その他の事故、お客様
     の故意若しくは過失、誤用その他異常な条件下での使用において生じた
     場合、サイバーコアは、保証の責任を負わないものとします。
     また、改造、改変、不当な修理、その他の取扱いが適切でなかったこと
     による故障も保証の対象とはなりません。
 (d) サイバーコアは、本ソフトウェア製品、本ソフトウェア製品の媒体または
     マニュアル、印刷物に関して、本保証規定に規定されていないその他の
     保証を一切いたしません。
 (g) サイバーコアは、いかなる場合においても、この製品の使用または使用不能
     から生ずる本保証規定に規定されていないいかなる他の損害に関して、一
     切責任を負わないものとします。
     いかなる場合においても、本保証規定に基づくサイバーコアの責任は、本
     ソフトウェア製品についてお客様が実際に支払った金額を上限とします。


OpenCV BSDライセンス

目次－導入編－OpenCV BSDライセンス

使用しているOpenCVとそのdllに関わるBSDライセンスについて条項の原文を以下に記します。

*********************************************************

IMPORTANT: READ BEFORE DOWNLOADING, COPYING, INSTALLING OR USING.

By downloading, copying, installing or using the software you agree to this license.
If you do not agree to this license, do not download, install,
copy or use the software.

                          License Agreement
               For Open Source Computer Vision Library
                       (3-clause BSD License)

Redistribution and use in source and binary forms, with or without modification,
are permitted provided that the following conditions are met:

  * Redistributions of source code must retain the above copyright notice,
    this list of conditions and the following disclaimer.

  * Redistributions in binary form must reproduce the above copyright notice,
    this list of conditions and the following disclaimer in the documentation
    and/or other materials provided with the distribution.

  * Neither the names of the copyright holders nor the names of the contributors
    may be used to endorse or promote products derived from this software
    without specific prior written permission.

This software is provided by the copyright holders and contributors "as is" and
any express or implied warranties, including, but not limited to, the implied
warranties of merchantability and fitness for a particular purpose are disclaimed.
In no event shall copyright holders or contributors be liable for any direct,
indirect, incidental, special, exemplary, or consequential damages
(including, but not limited to, procurement of substitute goods or services;
loss of use, data, or profits; or business interruption) however caused
and on any theory of liability, whether in contract, strict liability,
or tort (including negligence or otherwise) arising in any way out of
the use of this software, even if advised of the possibility of such damage.

**************************************************************


ffmpeg.dll　LGPライセンス

目次－導入編－ffmpeg.dll LGPライセンス

使用しているOpenCVに同梱されているffmpeg.dllに関わるLPGライセンスについて条項の原文を以下に記します。

**************************************************************

          GNU LESSER GENERAL PUBLIC LICENSE
               Version 2.1, February 1999

 Copyright (C) 1991, 1999 Free Software Foundation, Inc.
     59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 Everyone is permitted to copy and distribute verbatim copies
 of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL.  It also counts
 as the successor of the GNU Library Public License, version 2, hence
 the version number 2.1.]

                Preamble

  The licenses for most software are designed to take away your
freedom to share and change it.  By contrast, the GNU General Public
Licenses are intended to guarantee your freedom to share and change
free software--to make sure the software is free for all its users.

  This license, the Lesser General Public License, applies to some
specially designated software packages--typically libraries--of the
Free Software Foundation and other authors who decide to use it.  You
can use it too, but we suggest you first think carefully about whether
this license or the ordinary General Public License is the better
strategy to use in any particular case, based on the explanations below.

  When we speak of free software, we are referring to freedom of use,
not price.  Our General Public Licenses are designed to make sure that
you have the freedom to distribute copies of free software (and charge
for this service if you wish); that you receive source code or can get
it if you want it; that you can change the software and use pieces of
it in new free programs; and that you are informed that you can do
these things.

  To protect your rights, we need to make restrictions that forbid
distributors to deny you these rights or to ask you to surrender these
rights.  These restrictions translate to certain responsibilities for
you if you distribute copies of the library or if you modify it.

  For example, if you distribute copies of the library, whether gratis
or for a fee, you must give the recipients all the rights that we gave
you.  You must make sure that they, too, receive or can get the source
code.  If you link other code with the library, you must provide
complete object files to the recipients, so that they can relink them
with the library after making changes to the library and recompiling
it.  And you must show them these terms so they know their rights.

  We protect your rights with a two-step method: (1) we copyright the
library, and (2) we offer you this license, which gives you legal
permission to copy, distribute and/or modify the library.

  To protect each distributor, we want to make it very clear that
there is no warranty for the free library.  Also, if the library is
modified by someone else and passed on, the recipients should know
that what they have is not the original version, so that the original
author's reputation will not be affected by problems that might be
introduced by others.

  Finally, software patents pose a constant threat to the existence of
any free program.  We wish to make sure that a company cannot
effectively restrict the users of a free program by obtaining a
restrictive license from a patent holder.  Therefore, we insist that
any patent license obtained for a version of the library must be
consistent with the full freedom of use specified in this license.

  Most GNU software, including some libraries, is covered by the
ordinary GNU General Public License.  This license, the GNU Lesser
General Public License, applies to certain designated libraries, and
is quite different from the ordinary General Public License.  We use
this license for certain libraries in order to permit linking those
libraries into non-free programs.

  When a program is linked with a library, whether statically or using
a shared library, the combination of the two is legally speaking a
combined work, a derivative of the original library.  The ordinary
General Public License therefore permits such linking only if the
entire combination fits its criteria of freedom.  The Lesser General
Public License permits more lax criteria for linking other code with
the library.

  We call this license the "Lesser" General Public License because it
does Less to protect the user's freedom than the ordinary General
Public License.  It also provides other free software developers Less
of an advantage over competing non-free programs.  These disadvantages
are the reason we use the ordinary General Public License for many
libraries.  However, the Lesser license provides advantages in certain
special circumstances.

  For example, on rare occasions, there may be a special need to
encourage the widest possible use of a certain library, so that it becomes
a de-facto standard.  To achieve this, non-free programs must be
allowed to use the library.  A more frequent case is that a free
library does the same job as widely used non-free libraries.  In this
case, there is little to gain by limiting the free library to free
software only, so we use the Lesser General Public License.

  In other cases, permission to use a particular library in non-free
programs enables a greater number of people to use a large body of
free software.  For example, permission to use the GNU C Library in
non-free programs enables many more people to use the whole GNU
operating system, as well as its variant, the GNU/Linux operating
system.

  Although the Lesser General Public License is Less protective of the
users' freedom, it does ensure that the user of a program that is
linked with the Library has the freedom and the wherewithal to run
that program using a modified version of the Library.

  The precise terms and conditions for copying, distribution and
modification follow.  Pay close attention to the difference between a
"work based on the library" and a "work that uses the library".  The
former contains code derived from the library, whereas the latter must
be combined with the library in order to run.

          GNU LESSER GENERAL PUBLIC LICENSE
   TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

  0. This License Agreement applies to any software library or other
program which contains a notice placed by the copyright holder or
other authorized party saying it may be distributed under the terms of
this Lesser General Public License (also called "this License").
Each licensee is addressed as "you".

  A "library" means a collection of software functions and/or data
prepared so as to be conveniently linked with application programs
(which use some of those functions and data) to form executables.

  The "Library", below, refers to any such software library or work
which has been distributed under these terms.  A "work based on the
Library" means either the Library or any derivative work under
copyright law: that is to say, a work containing the Library or a
portion of it, either verbatim or with modifications and/or translated
straightforwardly into another language.  (Hereinafter, translation is
included without limitation in the term "modification".)

  "Source code" for a work means the preferred form of the work for
making modifications to it.  For a library, complete source code means
all the source code for all modules it contains, plus any associated
interface definition files, plus the scripts used to control compilation
and installation of the library.

  Activities other than copying, distribution and modification are not
covered by this License; they are outside its scope.  The act of
running a program using the Library is not restricted, and output from
such a program is covered only if its contents constitute a work based
on the Library (independent of the use of the Library in a tool for
writing it).  Whether that is true depends on what the Library does
and what the program that uses the Library does.

  1. You may copy and distribute verbatim copies of the Library's
complete source code as you receive it, in any medium, provided that
you conspicuously and appropriately publish on each copy an
appropriate copyright notice and disclaimer of warranty; keep intact
all the notices that refer to this License and to the absence of any
warranty; and distribute a copy of this License along with the
Library.

  You may charge a fee for the physical act of transferring a copy,
and you may at your option offer warranty protection in exchange for a
fee.

  2. You may modify your copy or copies of the Library or any portion
of it, thus forming a work based on the Library, and copy and
distribute such modifications or work under the terms of Section 1
above, provided that you also meet all of these conditions:

    a) The modified work must itself be a software library.

    b) You must cause the files modified to carry prominent notices
    stating that you changed the files and the date of any change.

    c) You must cause the whole of the work to be licensed at no
    charge to all third parties under the terms of this License.

    d) If a facility in the modified Library refers to a function or a
    table of data to be supplied by an application program that uses
    the facility, other than as an argument passed when the facility
    is invoked, then you must make a good faith effort to ensure that,
    in the event an application does not supply such function or
    table, the facility still operates, and performs whatever part of
    its purpose remains meaningful.

    (For example, a function in a library to compute square roots has
    a purpose that is entirely well-defined independent of the
    application.  Therefore, Subsection 2d requires that any
    application-supplied function or table used by this function must
    be optional: if the application does not supply it, the square
    root function must still compute square roots.)

These requirements apply to the modified work as a whole.  If
identifiable sections of that work are not derived from the Library,
and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those
sections when you distribute them as separate works.  But when you
distribute the same sections as part of a whole which is a work based
on the Library, the distribution of the whole must be on the terms of
this License, whose permissions for other licensees extend to the
entire whole, and thus to each and every part regardless of who wrote
it.

Thus, it is not the intent of this section to claim rights or contest
your rights to work written entirely by you; rather, the intent is to
exercise the right to control the distribution of derivative or
collective works based on the Library.

In addition, mere aggregation of another work not based on the Library
with the Library (or with a work based on the Library) on a volume of
a storage or distribution medium does not bring the other work under
the scope of this License.

  3. You may opt to apply the terms of the ordinary GNU General Public
License instead of this License to a given copy of the Library.  To do
this, you must alter all the notices that refer to this License, so
that they refer to the ordinary GNU General Public License, version 2,
instead of to this License.  (If a newer version than version 2 of the
ordinary GNU General Public License has appeared, then you can specify
that version instead if you wish.)  Do not make any other change in
these notices.

  Once this change is made in a given copy, it is irreversible for
that copy, so the ordinary GNU General Public License applies to all
subsequent copies and derivative works made from that copy.

  This option is useful when you wish to copy part of the code of
the Library into a program that is not a library.

  4. You may copy and distribute the Library (or a portion or
derivative of it, under Section 2) in object code or executable form
under the terms of Sections 1 and 2 above provided that you accompany
it with the complete corresponding machine-readable source code, which
must be distributed under the terms of Sections 1 and 2 above on a
medium customarily used for software interchange.

  If distribution of object code is made by offering access to copy
from a designated place, then offering equivalent access to copy the
source code from the same place satisfies the requirement to
distribute the source code, even though third parties are not
compelled to copy the source along with the object code.

  5. A program that contains no derivative of any portion of the
Library, but is designed to work with the Library by being compiled or
linked with it, is called a "work that uses the Library".  Such a
work, in isolation, is not a derivative work of the Library, and
therefore falls outside the scope of this License.

  However, linking a "work that uses the Library" with the Library
creates an executable that is a derivative of the Library (because it
contains portions of the Library), rather than a "work that uses the
library".  The executable is therefore covered by this License.
Section 6 states terms for distribution of such executables.

  When a "work that uses the Library" uses material from a header file
that is part of the Library, the object code for the work may be a
derivative work of the Library even though the source code is not.
Whether this is true is especially significant if the work can be
linked without the Library, or if the work is itself a library.  The
threshold for this to be true is not precisely defined by law.

  If such an object file uses only numerical parameters, data
structure layouts and accessors, and small macros and small inline
functions (ten lines or less in length), then the use of the object
file is unrestricted, regardless of whether it is legally a derivative
work.  (Executables containing this object code plus portions of the
Library will still fall under Section 6.)

  Otherwise, if the work is a derivative of the Library, you may
distribute the object code for the work under the terms of Section 6.
Any executables containing that work also fall under Section 6,
whether or not they are linked directly with the Library itself.

  6. As an exception to the Sections above, you may also combine or
link a "work that uses the Library" with the Library to produce a
work containing portions of the Library, and distribute that work
under terms of your choice, provided that the terms permit
modification of the work for the customer's own use and reverse
engineering for debugging such modifications.

  You must give prominent notice with each copy of the work that the
Library is used in it and that the Library and its use are covered by
this License.  You must supply a copy of this License.  If the work
during execution displays copyright notices, you must include the
copyright notice for the Library among them, as well as a reference
directing the user to the copy of this License.  Also, you must do one
of these things:

    a) Accompany the work with the complete corresponding
    machine-readable source code for the Library including whatever
    changes were used in the work (which must be distributed under
    Sections 1 and 2 above); and, if the work is an executable linked
    with the Library, with the complete machine-readable "work that
    uses the Library", as object code and/or source code, so that the
    user can modify the Library and then relink to produce a modified
    executable containing the modified Library.  (It is understood
    that the user who changes the contents of definitions files in the
    Library will not necessarily be able to recompile the application
    to use the modified definitions.)

    b) Use a suitable shared library mechanism for linking with the
    Library.  A suitable mechanism is one that (1) uses at run time a
    copy of the library already present on the user's computer system,
    rather than copying library functions into the executable, and (2)
    will operate properly with a modified version of the library, if
    the user installs one, as long as the modified version is
    interface-compatible with the version that the work was made with.

    c) Accompany the work with a written offer, valid for at
    least three years, to give the same user the materials
    specified in Subsection 6a, above, for a charge no more
    than the cost of performing this distribution.

    d) If distribution of the work is made by offering access to copy
    from a designated place, offer equivalent access to copy the above
    specified materials from the same place.

    e) Verify that the user has already received a copy of these
    materials or that you have already sent this user a copy.

  For an executable, the required form of the "work that uses the
Library" must include any data and utility programs needed for
reproducing the executable from it.  However, as a special exception,
the materials to be distributed need not include anything that is
normally distributed (in either source or binary form) with the major
components (compiler, kernel, and so on) of the operating system on
which the executable runs, unless that component itself accompanies
the executable.

  It may happen that this requirement contradicts the license
restrictions of other proprietary libraries that do not normally
accompany the operating system.  Such a contradiction means you cannot
use both them and the Library together in an executable that you
distribute.

  7. You may place library facilities that are a work based on the
Library side-by-side in a single library together with other library
facilities not covered by this License, and distribute such a combined
library, provided that the separate distribution of the work based on
the Library and of the other library facilities is otherwise
permitted, and provided that you do these two things:

    a) Accompany the combined library with a copy of the same work
    based on the Library, uncombined with any other library
    facilities.  This must be distributed under the terms of the
    Sections above.

    b) Give prominent notice with the combined library of the fact
    that part of it is a work based on the Library, and explaining
    where to find the accompanying uncombined form of the same work.

  8. You may not copy, modify, sublicense, link with, or distribute
the Library except as expressly provided under this License.  Any
attempt otherwise to copy, modify, sublicense, link with, or
distribute the Library is void, and will automatically terminate your
rights under this License.  However, parties who have received copies,
or rights, from you under this License will not have their licenses
terminated so long as such parties remain in full compliance.

  9. You are not required to accept this License, since you have not
signed it.  However, nothing else grants you permission to modify or
distribute the Library or its derivative works.  These actions are
prohibited by law if you do not accept this License.  Therefore, by
modifying or distributing the Library (or any work based on the
Library), you indicate your acceptance of this License to do so, and
all its terms and conditions for copying, distributing or modifying
the Library or works based on it.

  10. Each time you redistribute the Library (or any work based on the
Library), the recipient automatically receives a license from the
original licensor to copy, distribute, link with or modify the Library
subject to these terms and conditions.  You may not impose any further
restrictions on the recipients' exercise of the rights granted herein.
You are not responsible for enforcing compliance by third parties with
this License.

  11. If, as a consequence of a court judgment or allegation of patent
infringement or for any other reason (not limited to patent issues),
conditions are imposed on you (whether by court order, agreement or
otherwise) that contradict the conditions of this License, they do not
excuse you from the conditions of this License.  If you cannot
distribute so as to satisfy simultaneously your obligations under this
License and any other pertinent obligations, then as a consequence you
may not distribute the Library at all.  For example, if a patent
license would not permit royalty-free redistribution of the Library by
all those who receive copies directly or indirectly through you, then
the only way you could satisfy both it and this License would be to
refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any
particular circumstance, the balance of the section is intended to apply,
and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any
patents or other property right claims or to contest validity of any
such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system which is
implemented by public license practices.  Many people have made
generous contributions to the wide range of software distributed
through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing
to distribute software through any other system and a licensee cannot
impose that choice.

This section is intended to make thoroughly clear what is believed to
be a consequence of the rest of this License.

  12. If the distribution and/or use of the Library is restricted in
certain countries either by patents or by copyrighted interfaces, the
original copyright holder who places the Library under this License may add
an explicit geographical distribution limitation excluding those countries,
so that distribution is permitted only in or among countries not thus
excluded.  In such case, this License incorporates the limitation as if
written in the body of this License.

  13. The Free Software Foundation may publish revised and/or new
versions of the Lesser General Public License from time to time.
Such new versions will be similar in spirit to the present version,
but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number.  If the Library
specifies a version number of this License which applies to it and
"any later version", you have the option of following the terms and
conditions either of that version or of any later version published by
the Free Software Foundation.  If the Library does not specify a
license version number, you may choose any version ever published by
the Free Software Foundation.

  14. If you wish to incorporate parts of the Library into other free
programs whose distribution conditions are incompatible with these,
write to the author to ask for permission.  For software which is
copyrighted by the Free Software Foundation, write to the Free
Software Foundation; we sometimes make exceptions for this.  Our
decision will be guided by the two goals of preserving the free status
of all derivatives of our free software and of promoting the sharing
and reuse of software generally.

                NO WARRANTY

  15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO
WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR
OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE.  THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
LIBRARY IS WITH YOU.  SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME
THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

  16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN
WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY
AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU
FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE
LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING
RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A
FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF
SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
DAMAGES.

             END OF TERMS AND CONDITIONS

           How to Apply These Terms to Your New Libraries

  If you develop a new library, and you want it to be of the greatest
possible use to the public, we recommend making it free software that
everyone can redistribute and change.  You can do so by permitting
redistribution under these terms (or, alternatively, under the terms of the
ordinary General Public License).

  To apply these terms, attach the following notices to the library.  It is
safest to attach them to the start of each source file to most effectively
convey the exclusion of warranty; and each file should have at least the
"copyright" line and a pointer to where the full notice is found.

    Copyright (C)

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Lesser General Public
    License as published by the Free Software Foundation; either
    version 2 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Lesser General Public License for more details.

    You should have received a copy of the GNU Lesser General Public
    License along with this library; if not, write to the Free Software
    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA

Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your
school, if any, to sign a "copyright disclaimer" for the library, if
necessary.  Here is a sample; alter the names:

  Yoyodyne, Inc., hereby disclaims all copyright interest in the
  library `Frob' (a library for tweaking knobs) written by James Random Hacker.

  , 1 April 1990
  Ty Coon, President of Vice

That's all there is to it!

**************************************************************


メイン画面

目次－実用編－メイン画面

LynxEye for Windows のメイン画面について解説します。

①　入力設定

ファイルの選択など入力に関する設定を行います。

②　出力設定

処理方式など出力に関する設定を行います。

③　プレビュー

処理結果イメージを確認できます。

④　処理部

処理を施して結果を出力します。

⑤　メニュー

ライセンス関連の操作やヘルプファイル(本書)の表示などが行えます。


入力設定

目次－実用編－入力設定

LynxEye for Windows の入力設定について解説します。

①　モード選択

処理モードをコンボボックスから選択します。

LynxEyeモード

画像処理を行うモードです。基本的にこちらを用います。

COPYモード

動画のFPSを調整するモードです。

画像処理を施した際、FPSが変わってしまった場合に用います。

②　ファイル選択ボタン

ファイル選択ダイアログより処理対象ファイルを選択します。

複数ファイル選択した場合は全てのファイルが処理されます。

③　ファイルリスト

ファイル選択ボタンにて選択されたファイルが追加表示されます。

④　リストクリアボタン

ファイルリストに表示されているファイルを全て削除します。


COPYモード

目次－実用編－COPYモード

LynxEye for Windows のCOPYモードついて解説します。

動画のFPSを調整するモードです。

画像処理を施した際、FPSが変わってしまった場合に用います。

①　モード選択

COPYモードを選択します。

②　ファイル選択ボタン

ファイル選択ダイアログより処理対象ファイルを選択します。

複数ファイル選択した場合は全てのファイルが処理されます。

③　ファイルリスト

ファイル選択ボタンにて選択されたファイルが追加表示されます。

④　FPS設定

調整したいFPSの値を入力します。

⑤　処理開始ボタン

COPYモード処理を始めます。

進捗バーに進捗度合いが表示され、処理結果は元ファイルと同じ場所に出力されます。


出力設定

目次－実用編－出力設定

LynxEye for Windows の出力設定について解説します。

①　色空間

処理を行う際の色空間について設定します。

HLS HSV YUV のいずれか、または3種全てで処理して出力する ALL を設定できます。

②　処理方式

処理を行う方式を設定します。

コントラスト強調処理 輪郭強調処理 逆光補正処理 またはそれらを合成した方式から設定します。

合成方式の場合にはその比率も設定できます。

※逆光補正処理は色空間YUVに非対応です。

③　ノイズリダクション

ノイズリダクションに関する設定をします。

除去レベル

ノイズを除去する強さを設定をします。

右へ行くほど強く、左へ行くほど弱くなり、左端に設定すると設定をOFFにする事できます。

※ノイズ除去は色空間YUVに非対応です。

明るさ補正(明)

ノイズ除去の結果、明るくなりすぎる事を補正する為の機能です。

右へ行くほど強く、左へ行くほど弱くなり、左端に設定すると設定をOFFにする事ができます。

※明るさ補正はコントラスト強調処理に非対応です。

明るさ補正(暗)

ノイズ除去の結果、暗くなりすぎる事を補正する為の機能です。

右へ行くほど強く、左へ行くほど弱くなり、左端に設定すると設定をOFFにする事ができます。

※明るさ補正はコントラスト強調処理に非対応です。

④　保存形式

処理結果の保存形式を設定します。

静止画の場合は BMP JPEG PNG のいずれか、動画の場合は 圧縮AVI 非圧縮MJPEG どちらかに設定できます。

⑤　プリセット

上記の各種設定をプリセットとして保存＆読み込みができます。


プレビュー

目次－実用編－プレビュー

LynxEye for Windows のプレビューについて解説します。

①　プレビューボタン

画像処理を開始する前に処理イメージを確認できます。

入力設定で選択中の対象に出力設定に基づいた処理イメージが表示されます。

②　プレビュー表示部

上側に処理前のイメージ、下側に処理後のイメージが表示されます。

③　範囲選択ボタン

範囲を限定して処理を行いたい場合に使用します。

ボタンクリック後に処理前イメージ内で範囲の始点、終点を設定すると指定範囲内のみ処理が行われたイメージが表示されます。

※範囲設定は複数ファイル選択中でも各々に反映されますが、全て現在プレビュー中の画像サイズ及び選択範囲サイズに準じます。

※色空間 ALL では表示対象が複数になるため非対応です。


処理部

目次－実用編－処理部

LynxEye for Windows の処理部について解説します。

①　処理開始ボタン

画像処理を実行します。

処理結果は元ファイルと同じ場所に出力されます。

出力されるファイル名の形式は

元ファイル名_処理方法_色空間.保存形式　の形式となります。

処理方式

E | コントラスト強調
R | 輪郭強調
S | 逆光補正
ER | コントラスト強調と輪郭強調
ES | コントラスト強調と逆光補正
RS | 輪郭強調と逆光補正

色空間

HLS
HSV
YUV

保存形式

BMP
JPG
PNG
AVI
MP4

②　進捗バー

画像処理の進捗と、そのステータスを表します。

③　終了

LynxEye for Windows を終了します。


メニュー

目次－実用編－メニュー

LynxEye for Windows のメニューについて解説します。

ファイル選択

ファイル選択ボタンと同様です。

リストクリア

リストクリアボタンと同様です。

終了

終了ボタンと同様です。

プレビュー

プレビューボタンと同様です。

範囲選択

範囲選択ボタンと同様です。

処理開始／中断

処理開始ボタンと同様です。

ライセンス情報

ライセンスに関する操作が行えます。

著作権情報

著作権に関する情報が表示されます。

ヘルプ

本書を開きます。

バージョン情報

LynxEye for Windows のバージョン情報を表示します。


ライセンス情報

目次－実用編－ライセンス情報

LynxEye for Windows のライセンス情報について解説します。

①　ライセンス認証

ライセンス認証の区分を表します。

②　ライセンス期間

ライセンス認証の期間を表します。

③　処理可能枚数

処理可能な残枚数を表示します。（試用版のみ制限あり）

④　ライセンス購入

ライセンス購入に必要な情報を表示します。

表示されているライセンスキー発行コードとご利用希望期間を併せて

lynxsupport@unitec-jpn.com　までご連絡をお願い致します。

⑤　ライセンス入力

ライセンス入力画面へ移行します。

入力欄に購入頂いたライセンスキーを入力して確定ボタンを押すと認証が完了します。

⑥　OK

メイン画面へ戻ります。


ノイズリダクション

目次－実用編－ノイズリダクション

ノイズリダクションについて解説します。

LynxEyeにて画像処理を施した結果現れるノイズに対して効果があります。

（※画像例では路上や壁に現れている緑、青、赤色のノイズ）

除去レベル

ノイズを除去する強さを設定をします。

右へ行くほど強く、左へ行くほど弱くなり、左端に設定すると設定をOFFにする事できます。

対象により適正な値は異なりますが、処理例を以下に記します。

除去レベル 2 の結果：効果が弱すぎてほぼ変化なし

除去レベル 5 の結果：概ね適正

除去レベル 8 の結果：効果が強すぎて全体的にモノクロ

明るさ補正(明)／明るさ補正(暗)

ノイズ除去の結果、明るくなりすぎる(明)、または暗くなりすぎる(暗)事を補正する為の機能です。

右へ行くほど強く、左へ行くほど弱くなり、左端に設定すると設定をOFFにする事ができます。

対象により適正な値は異なりますが、処理例を以下に記します。

明るさ補正(明) 0 の結果：補正なしの状態では明るくなりすぎている

明るさ補正(明) 2 の結果：概ね適正

明るさ補正(明) 6 の結果：補正が強すぎて暗くなってしまっている